The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Metrics
Affected Vendors & Products
References
History
Thu, 29 Oct 2026 07:45:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Weaknesses | CWE-79 |
Thu, 29 Oct 2026 06:15:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Description | The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup) | |
| Title | LetterPress < 2.4.0 - Admin+ Stored XSS | |
| References |
|
Status: PUBLISHED
Assigner: WPScan
Published: 2026-10-29T06:00:23.500Z
Updated: 2026-10-29T06:00:23.500Z
Reserved: 2024-04-10T14:12:39.458Z
Link: CVE-2024-3586
No data.
Status : Received
Published: 2026-10-29T06:17:16.020
Modified: 2026-10-29T06:17:16.020
Link: CVE-2024-3586
No data.